当前位置: 金桥电子资料网-电器维修行业资料门户网站 → 电脑相关软件,硬件网络硬件 → ROS双线adsl负载均衡配置过程
内容详细

ROS双线adsl负载均衡配置过程

作者:金桥电子  来源:本站整理  发布时间:2010-09-27 11:43:47

双线adsl负载均衡配置过程

先来看看配置之后的效果图



以下是详细配置过程:

1 标记连接和路由

配置mangle后的效果图



以下是详细配置过程

2 配置网关(此步之前需要先配置好pppoe,配置过程请到论坛上找)

由下图可知,我加了2条规则,分别对应两个pppoe获得的地址,特点是address=network=broadcast。

这样做的目的是让ros能够根据这里所设的网关分别路由。

注意comment中的1和2,再运行脚本时要用到。 \\





3 配置srcnat(ip伪装)

总配置效果图,注意comment的设置,在运行脚本时要用到



配置截图:







 

4 配置路由

总配置效果图,注意comment的设置,在运行脚本时要用到

可以看到,我在路由表中加入了3条规则,前两条分别对应于在mangle中设置的两个路由标记

另外一条没有路由标记,官方解释说是用于路由被标记之外的ros本身的包,具体什么意思我也没有彻底明白



5 加入防adsl掉线脚本

:local assign-address

:local new-address

:local status

:local x

:set x 2

:for i from=1 to=$x do={

:set status [/interface get [/interface find name=(\"pppoe-out\" . $i)] running]

:if ($status=true) do={

:set new-address [/ip address get [/ip address find dynamic=yes interface=(\"pppoe-out\" . $i)] address]

[1] [2]  下一页

  • 好的评价如果您觉得此文章好,就请您
      0%(0)
  • 差的评价如果您觉得此文章差,就请您
      0%(0)
  • 上一篇文章:TDA2822应用电路图集3
  • 下一篇文章:下一篇文章:ROS双线ADSL,不同网关按网段分流



  • 文章评论
       评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论
    栏目导航

    本类热门
      

    下载排行
    关于我们 | 网站帮助 | 广告合作 | 下载声明 | 免责声明 | 申请连接 | 付款方式 | 网站地图 | 返回顶部
  • 版权:Copyright©2009-2018 www.jqdzw.Com.  All Rights Reserved . 金桥电子网(连云港金云网络科技有限公司) 版权所有
  • 苏ICP备11037958号  苏公网安备 32072402010019号